Epilog:

Ich hatte vor, meinen Sharing-Ordner auf share.kayuk.de vom Uberspace auf den neuen Rootserver umzuziehen. Bisher wurde dieser per Dropzone mit dem beigelegten scp-script gefüttert.

Das funktioniert auch wunderbar. Das Problem war aber im nachhinein die Pflege der Daten die da oben auf dem Uberspace dann rumlagen. Insbesondere das Löschen von Sachen die nicht mehr gebraucht werden, denn jedes mal per SSH einloggen, nur um 2 Bilder zu löschen ist alles andere als bequem. Auch jedes mal per SFTP einloggen geht, aber schön is anders.

Der neue Plan:

Dank dem seit neustem von mir entdeckten Bittorrent Sync (danke nochmal an eXyr0w ;) ist der Ordner viel besser zu handeln (Vor allem für große Daten!).

Ich kann einfach am Rechner Daten löschen, die nicht mehr gebraucht werden und neue Daten hochschieben. Ein lokaler Ordner ist mit dem Sharing-Ordner auf dem Server verbunden und jede Veränderung wird automatisch synchronisiert. Wie in der Dropbox.

Problem:

Zum schönen browsen durch die Ordner habe ich h5ai auf dem Uberspace benutzt, was jetzt auf dem Rootserver leider Zicken machte bzw. gar nicht funktionierte.

Der Directory-Index war whitespace und die Server-Details-Anzeige in share.kayuk.de/_h5ai/ zeigte Fragezeichen anstatt yes und no.

Lösung: (Wenn du faul bist, bitte gleich hier anfagen zu lesen ;)

Ich hatte einen frisch aufgesetzten Server mit folgenden Specs:

  • Apache v2.4
  • Ubuntu 13.10 Kernel 3.11
  • h5ai v0.24.0

Die nötigen Pakete für Apache, PHP (und mySQL) wurden von Hand installiert, ich hatte keine LAMP-Installation als bundle. Bei meinen Recherchen nach der Problemlösung bin ich aber darauf gestoßen, dass das Problem auch bei LAMP-Installationen auftritt.

(An dieser Stelle möchte ich auf dieses Tutorial auf yaui.me hinweisen. Es ist zwar für ein Raspberry PI, aber dort wird Debian behandelt und es funktioniert auf Ubuntu alles analog.)

Alle Einstellungen waren richtig, die .htaccess Files waren im Apache mit AllowOverride All eingeschalten und die nötige Zeile für h5ai war auch in der Server-Config (DirectoryIndex index.html index.php /_h5ai/server/php/index.php, die kann entweder in eine .htaccess oder direkt in die httpd.conf oder in die entsprechende Datei in /etc/apache2/sites-available/).

Der _h5ai - Ordner war auch am richtigen Platz.

Alle nötigen Pakete waren installiert. Alle nötigen Module für den Apache Server waren geladen. Dachte ich. Zwischenzeitlich probierte ich noch einmal h5ai auf meinem Homeserver aus (Apache 2.22.2), wo es tadellos und auf Anhieb funktionierte. Zurück auf dem Rootserver - noch immer Fragezeichen.

Bis ich irgendwann auf dieses Issue stieß.

Das Paket, das Fehlte war also php5-json, bzw php-json. Klar, h5ai benutzt json um seine Configs zu parsen, weil die ja in json geschrieben sind, Depp!

Dann also schnell:

sudo apt-get install php5-json

sudo a2enmod rewrite

und schließlich

sudo service apache2 reload

Und siehe da - It works!

Dann noch ein paar Pakete nachgeladen, die in der Server-Details-Anzeige im h5ai noch gefehlt haben und fertig.